Android 11 Wifi no internet, even though there is internet


Edit: after getting the hint to try creating a new SSID on my WiFi router, I now resolved the problem by just connecting to the same router but with a separate SSID. I still have no idea what the problem was, and the solution now is also completely unrelated to Android. I guess I'll never know what the problem was, but there's no reason anymore for others to try and diagnose the issue.

I know that remotely diagnosing WiFi issues can be very difficult, but I'm running out of ideas (and time) what I could try to identify the cause of the issue I'm having. Therefore, I'm trying to give as much detail as possible and the main advice I'm asking for is what I can do to diagnose the issue.

Since approximately last weekend (I didn't notice right away), I have a very annoying WiFi connection issue on Pixel 3a, Android 11. Android tells me that I have no internet connection through the WiFi network, but in Google Chrome (or Firefox), any pages not related to Google load just fine. for example, and do not load., and do also not load (details below, this is because they load stuff from or similar URLs). loads.

This issue is extremely annoying since apps by Google are also not working, so I don't get new e-mails, the calendar does not synchronize and I cannot use Google Play, for example. I do only have very limited mobile data available which I use when I do not have access to WiFi, so I don't want to simply switch to using mobile data (which works fine). I tried restarting the phone in safe mode (it first seemed to work, but the issue now also persists in safe mode) and uninstalling different apps from my phone, but while the issue disappeared sometimes for a few minutes, it came back every time.

I restarted the phone a lot of times, I deleted the WiFi network and reconnected, I tried setting the network rating provider to none and in general turning different WiFi settings off and on, and I slowly run out of ideas. WiFi works fine on my laptop connected to the same network. Resetting the router seemed to help first, but again the issue reappeared after a few minutes (just like after some of the restarts: sometimes it works for a few minutes but mostly it says no connection right after the device powered up). Connecting through a hotspot created using my laptop which uses the same WiFi network works. Unfortunately, this is not a long-term solution. Also, the router is not easily accessible for me, so it's difficult to debug router issues if this is a router issue. But the issue concerns only my phone (not the printer, not the laptop, nor devices of other users of the same network; it's not a public WiFi network if anyone was wondering). Any ideas what else I could try?

I'm not 100% sure that this is an issue with the Android phone alone, but since the WiFi network works with all other devices and since only Google-related URLs seem to be affected, I think it is highly likely that the root issue is indeed caused by Android.

Below you can find an extended log of attempts to get to the root of the problem:

I did now get access to the router (a FritzBox) and captured network traffic. I had a look at it in Wireshark: to me, it looks like my phone goes silent / doesn't get or process the TCP syn ack after the initial TCP syn when running a request for Not sure why...

Head requests to and using curl on my phone during a short period when everything was working (white bars = my phone's IP address): and head requests success

Head requests to and using curl on my phone while the issue was present ( works, doesn't): and head requests timeout

Using PCAPdroid (Google Play Link, I don't want to root my device) seems to suggest that the TCP syn ack never reaches the app / phone...

Here are some screenshots made using chrome://inspect from trying to load different pages:

(no issue)

(issue here is jquery.min.js from

Some screenshots of how it looks on the phone (in German):

Loading, trying to load (see address bar), and the same issue in safe mode:

working fine not working not working

Ping results:

***>adb shell ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=118 time=49.8 ms
64 bytes from ( icmp_seq=2 ttl=118 time=761 ms
64 bytes from ( icmp_seq=3 ttl=118 time=473 ms
64 bytes from ( icmp_seq=4 ttl=118 time=627 ms
***>adb shell ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=59 time=2003 ms
64 bytes from icmp_seq=2 ttl=59 time=1000 ms
64 bytes from icmp_seq=3 ttl=59 time=499 ms
64 bytes from icmp_seq=4 ttl=59 time=981 ms
64 bytes from icmp_seq=5 ttl=59 time=273 ms
64 bytes from icmp_seq=6 ttl=59 time=1544 ms

for comparison, this is how it looks if I ping directly from my laptop:

***>ping -4

Ping wird ausgeführt für [] mit 32 Bytes Daten:
Antwort von Bytes=32 Zeit=6ms TTL=118
Antwort von Bytes=32 Zeit=7ms TTL=118
Antwort von Bytes=32 Zeit=7ms TTL=118
Antwort von Bytes=32 Zeit=7ms TTL=118

Ping-Statistik für
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 6ms, Maximum = 7ms, Mittelwert = 6ms

Output of curl using Termux: works doesn't work

If I do a ping using Termux terminal, I get the same result as for adb shell ping

PS: since you can see the Avast icon on the last two screenshots: I had it uninstalled for quite some time without any improvement.

Traceroute output:

On Termux, directly connected to the WiFi network:

traceroute -b
1: ([IPv6 address]) 2.692ms
1: ([IPv6 address]) 3.035ms
2: [IPv6 address] ([IPv6 address]) 8.353ms
3: no reply
4: no reply

Same on my laptop:


Routenverfolgung zu [2a00:1450:4016:803::2004]
über maximal 30 Hops:

1 2 ms 3 ms 1 ms [same IPv6 address as for Termux hop 1]
2 8 ms 10 ms 6 ms [same IPv6 address as for Termux hop 2]
3 * * * Zeitüberschreitung der Anforderung. [<- timeout]
4 7 ms 6 ms 8 ms [IPv6 address]
5 6 ms 7 ms 8 ms [IPv6 address]
6 6 ms 6 ms 8 ms [IPv6 address]
7 6 ms 7 ms 6 ms [IPv6 address]
8 143 ms * * [IPv6 address]
9 6 ms 6 ms 8 ms [IPv6 address]
10 6 ms 6 ms 5 ms [2a00:1450:4016:803::2004]

Ablaufverfolgung beendet.

On Termux, connected to the WiFi network via mobile hotspot on my laptop:

traceroute -b
1: [...] ([IPv4 address]) 75.818ms
1: [...] ([IPv4 address]) 2.957ms
2: no reply
3: ([IPv4 address]) 142.428ms asymm 2
4: [IPv4 address] ([IPv4 address]) 1018.851ms asymm 3
4: [IPv4 address] ([IPv4 address]) 134.135ms asymm 3
5: [ISP server address] ([IPv4 address]) 103.956ms asymm 8
6: [IPv4 address] ([IPv4 address]) 182.587ms asymm 9
7: no reply
8: no reply

Same on my laptop:

***>tracert -4

Routenverfolgung zu []
über maximal 30 Hops:

1 3 ms 3 ms 1 ms [same IPv4 address as for Termux hop 3]
2 52 ms 6 ms 6 ms [same IPv4 address as for Termux hop 4]
3 7 ms 55 ms 6 ms [ISP server address] [same IPv4 address as for Termux hop 5]
4 32 ms 6 ms 6 ms [same IPv4 address as for Termux hop 6]
5 9 ms 54 ms 7 ms [IPv4 address]
6 8 ms 47 ms 7 ms [IPv4 address]
7 7 ms 6 ms 50 ms []

Ablaufverfolgung beendet.


Adding as an answer since it worked.

It seems that for some reason, your phone may have an issue with the existing SSID that you use. Create a new SSID on your router and use that to connect your phone.


2D Engines   3D Engines   9-Patch   Action Bars   Activities   ADB   Advertisements   Analytics   Animations   ANR   AOP   API   APK   APT   Architecture   Audio   Autocomplete   Background Processing   Backward Compatibility   Badges   Bar Codes   Benchmarking   Bitmaps   Bluetooth   Blur Effects   Bread Crumbs   BRMS   Browser Extensions   Build Systems   Bundles   Buttons   Caching   Camera   Canvas   Cards   Carousels   Changelog   Checkboxes   Cloud Storages   Color Analysis   Color Pickers   Colors   Comet/Push   Compass Sensors   Conferences   Content Providers   Continuous Integration   Crash Reports   Credit Cards   Credits   CSV   Curl/Flip   Data Binding   Data Generators   Data Structures   Database   Database Browsers   Date &   Debugging   Decompilers   Deep Links   Dependency Injections   Design   Design Patterns   Dex   Dialogs   Distributed Computing   Distribution Platforms   Download Managers   Drawables   Emoji   Emulators   EPUB   Equalizers &   Event Buses   Exception Handling   Face Recognition   Feedback &   File System   File/Directory   Fingerprint   Floating Action   Fonts   Forms   Fragments   FRP   FSM   Functional Programming   Gamepads   Games   Geocaching   Gestures   GIF   Glow Pad   Gradle Plugins   Graphics   Grid Views   Highlighting   HTML   HTTP Mocking   Icons   IDE   IDE Plugins   Image Croppers   Image Loaders   Image Pickers   Image Processing   Image Views   Instrumentation   Intents   Job Schedulers   JSON   Keyboard   Kotlin   Layouts   Library Demos   List View   List Views   Localization   Location   Lock Patterns   Logcat   Logging   Mails   Maps   Markdown   Mathematics   Maven Plugins   MBaaS   Media   Menus   Messaging   MIME   Mobile Web   Native Image   Navigation   NDK   Networking   NFC   NoSQL   Number Pickers   OAuth   Object Mocking   OCR Engines   OpenGL   ORM   Other Pickers   Parallax List   Parcelables   Particle Systems   Password Inputs   PDF   Permissions   Physics Engines   Platforms   Plugin Frameworks   Preferences   Progress Indicators   ProGuard   Properties   Protocol Buffer   Pull To   Purchases   Push/Pull   QR Codes   Quick Return   Radio Buttons   Range Bars   Ratings   Recycler Views   Resources   REST   Ripple Effects   RSS   Screenshots   Scripting   Scroll Views   SDK   Search Inputs   Security   Sensors   Services   Showcase Views   Signatures   Sliding Panels   Snackbars   SOAP   Social Networks   Spannable   Spinners   Splash Screens   SSH   Static Analysis   Status Bars   Styling   SVG   System   Tags   Task Managers   TDD &   Template Engines   Testing   Testing Tools   Text Formatting   Text Views   Text Watchers   Text-to   Toasts   Toolkits For   Tools   Tooltips   Trainings   TV   Twitter   Updaters   USB   User Stories   Utils   Validation   Video   View Adapters   View Pagers   Views   Watch Face   Wearable Data   Wearables   Weather   Web Tools   Web Views   WebRTC   WebSockets   Wheel Widgets   Wi-Fi   Widgets   Windows   Wizards   XML   XMPP   YAML   ZIP Codes