LG V20 not recognized by MTP apps when in MTP mode on Mac


Problem Summary

Neither Android File Transfer nor OpenMTP will detect an LG V20, model LG-H910, over USB when it's in MTP mode. The phone is detected by them in other USB modes, there are no issues with connecting to the phone via adb and the phone will mount under Windows. Changing cables and computers makes no difference. MTP works fine with an LG V20 LG-LS997.


I've got an (unrooted) AT&T branded LG V20, model LG-H910. I'm trying to transfer files over USB, but neither GUI MTP app I've tried for Macs (Android File Transfer 1.0.12; OpenMTP 3.1.10 & 3.1.15) will detect the phone when it's in MTP mode; they present "No Android device found" and "Android device is either busy or not connected" messages, respectively. When the phone is set to charge-only, each MTP app detects the phone but rightly can't connect (reporting "Can't access device storage" and "Your phone storage is inaccessible.", respectively). Image Capture connects to the phone when it's in PTP mode, though can't pull images (this also happens with another LG V20, so it's not surprising).

As a test, mtpfs (installed via MacPorts) will recognize the phone (though misidentifies it) and supposedly mount it, but all attempts to access the files via the mount result in a "Device not configured" error. Sample local shell session:

$ sudo -s
# mkdir /Volumes/phone
# mtpfs /Volumes/phone
Listing raw device(s)
Device 0 (VID=1004 and PID=633e) is a LG Electronics Inc. LG G Flex 2.
Found 1 device(s):
LG Electronics Inc.: LG G Flex 2 (1004:633e) @ bus 20, dev 29
Attempting to connect device
desired configuration different from current, trying to set configuration
libusb_set_configuration() failed, continuing anyway...: Operation timed out
Android device detected, assigning default bug flags
Listing File Information on Device with name: V20
# ls /Volumes/phone
ls: : Device not configured

mtpfs has other issues, such as taking about 1 minute to run (there's about
a 1 minute pause before the last line of output, beginning "Listing File Information [...]"). I'm not so much interested in mtpfs as a solution as I was using it to test MTP on the phone.

Whether USB Debugging is enabled or not makes no difference to MTP, though when enabled, the phone is accessible via adb, both from the command line and in Android Studio (I can run a shell on the phone, pull files, install & debug apps in Android Studio &c.).

AFT didn't log any messages to the system console when the phone was connected in MTP mode.

There were no file access issues with the LG-H910 when connected to a Windows computer (both internal & external storage mounted, and the files were accessible). AFT and OpenMTP detect and can access a different phone of the same type, an (unrooted) Sprint-branded LG V20, model LG-LS997.

I've tried rebooting phone & computer, ejecting the SD card in the phone & rebooting, different cables, different ports and different computers (both Macs, one with a clean install of OS X); nothing had any impact on the issue, and the only common factors are the LG-H910 and OS X. A factory reset of the LG-H910 made no difference.


How can I get AFT (or even OpenMTP) working with the LG V20 LG-H910? What other troubleshooting steps can I take?

Related questions

There are similar questions on this site, but none seem to describe the same situation, or have solutions.

There are plenty more questions, but all are either AFT isn't installed, AFT detects the phone, or the phone isn't detected by anything.

System Info

  • mid-2012 13" MacBook Pro

  • MacOS 10.14.6

  • Android 8.0.0 (both phones)

  • Android File Transfer 1.0.12

  • OpenMTP 3.1.10, 3.1.15

  • mtpfs 1.1


The Answer

The LG Mobile Drivers, installed by LG Bridge, interfered with MTP operation on the LG V20 LG-H910.

The Process

Going off of Robert's comment, I disabled all kernel extensions in /Library/Extensions (which were all 3rd party extensions) by moving them to "/Library/Extensions (disabled)" and restarted. Android File Transfer was then able to detect and connect to the LG-H910. Among the extensions were a number of extensions with names beginning "lgandroid_", which are the LG Mobile Drivers.

After re-enabling all but these extensions and restarting, AFT still worked with the LG-H910. After enabling the LG extensions and restarting, AFT stopped detecting the LG-H910. So, after a final round of disabling the LG extensions, AFT was working.

Originally, v 5.4 of the extensions were installed. I tried the newest, v 6.1, but they had the same issue (which has been reported to LG). LG Bridge, when run, asks to install extensions, which turn out to be the LG Mobile Drivers; with the drivers disabled, LG Bridge won't function (not a big concern to me, but for others with the same issue, you'll probably need to reinstate the drivers before using LG Bridge, and then disable them & restart afterwards).


2D Engines   3D Engines   9-Patch   Action Bars   Activities   ADB   Advertisements   Analytics   Animations   ANR   AOP   API   APK   APT   Architecture   Audio   Autocomplete   Background Processing   Backward Compatibility   Badges   Bar Codes   Benchmarking   Bitmaps   Bluetooth   Blur Effects   Bread Crumbs   BRMS   Browser Extensions   Build Systems   Bundles   Buttons   Caching   Camera   Canvas   Cards   Carousels   Changelog   Checkboxes   Cloud Storages   Color Analysis   Color Pickers   Colors   Comet/Push   Compass Sensors   Conferences   Content Providers   Continuous Integration   Crash Reports   Credit Cards   Credits   CSV   Curl/Flip   Data Binding   Data Generators   Data Structures   Database   Database Browsers   Date &   Debugging   Decompilers   Deep Links   Dependency Injections   Design   Design Patterns   Dex   Dialogs   Distributed Computing   Distribution Platforms   Download Managers   Drawables   Emoji   Emulators   EPUB   Equalizers &   Event Buses   Exception Handling   Face Recognition   Feedback &   File System   File/Directory   Fingerprint   Floating Action   Fonts   Forms   Fragments   FRP   FSM   Functional Programming   Gamepads   Games   Geocaching   Gestures   GIF   Glow Pad   Gradle Plugins   Graphics   Grid Views   Highlighting   HTML   HTTP Mocking   Icons   IDE   IDE Plugins   Image Croppers   Image Loaders   Image Pickers   Image Processing   Image Views   Instrumentation   Intents   Job Schedulers   JSON   Keyboard   Kotlin   Layouts   Library Demos   List View   List Views   Localization   Location   Lock Patterns   Logcat   Logging   Mails   Maps   Markdown   Mathematics   Maven Plugins   MBaaS   Media   Menus   Messaging   MIME   Mobile Web   Native Image   Navigation   NDK   Networking   NFC   NoSQL   Number Pickers   OAuth   Object Mocking   OCR Engines   OpenGL   ORM   Other Pickers   Parallax List   Parcelables   Particle Systems   Password Inputs   PDF   Permissions   Physics Engines   Platforms   Plugin Frameworks   Preferences   Progress Indicators   ProGuard   Properties   Protocol Buffer   Pull To   Purchases   Push/Pull   QR Codes   Quick Return   Radio Buttons   Range Bars   Ratings   Recycler Views   Resources   REST   Ripple Effects   RSS   Screenshots   Scripting   Scroll Views   SDK   Search Inputs   Security   Sensors   Services   Showcase Views   Signatures   Sliding Panels   Snackbars   SOAP   Social Networks   Spannable   Spinners   Splash Screens   SSH   Static Analysis   Status Bars   Styling   SVG   System   Tags   Task Managers   TDD &   Template Engines   Testing   Testing Tools   Text Formatting   Text Views   Text Watchers   Text-to   Toasts   Toolkits For   Tools   Tooltips   Trainings   TV   Twitter   Updaters   USB   User Stories   Utils   Validation   Video   View Adapters   View Pagers   Views   Watch Face   Wearable Data   Wearables   Weather   Web Tools   Web Views   WebRTC   WebSockets   Wheel Widgets   Wi-Fi   Widgets   Windows   Wizards   XML   XMPP   YAML   ZIP Codes